Instability issues with SafetyCulture (iAuditor) in the US region
Incident Report for SafetyCulture
Resolved
This incident has been resolved.
Posted Jun 06, 2023 - 08:41 UTC
Monitoring
We're aware of an instability issue for SafetyCulture (iAuditor) in the US region. Our team is looking into this issue and we apologise for any inconvenience caused.
Posted Jun 06, 2023 - 08:21 UTC
This incident affected: SafetyCulture (formerly iAuditor) (Inspections, Issues, Sensors, Assets, Analytics, Public Library, Heads Up, Public API, Mobile App, Web Platform, Training, Actions).