Delays in weather sensor readings

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted May 28, 2026 - 08:38 UTC

Monitoring

Readings are beginning to stabilize and are coming through more regularly.

We are monitoring the readings and data ingestion.
Posted May 28, 2026 - 08:01 UTC

Investigating

We are aware of an issue where weather sensor readings have delays.

Our engineers are already looking into this.
Posted May 28, 2026 - 07:55 UTC
This incident affected: SafetyCulture (Sensors).