Weather sensors may be experiencing delays in receiving the latest weather readings.
Incident Report for SafetyCulture
Resolved
This incident has been resolved.
Posted Dec 05, 2023 - 20:51 UTC
Update
We are continuing to investigate this issue.

We apologize for any inconvenience caused.
Posted Dec 05, 2023 - 14:54 UTC
Investigating
Customers with weather sensors may be experiencing delays in receiving the latest weather readings.

We are investigating the cause.
Posted Dec 05, 2023 - 12:24 UTC
This incident affected: SafetyCulture (formerly iAuditor) (Sensors).