Dynamic groups and sites experiencing delays for some customers

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 07:56 UTC

Investigating

We're aware that there are delays affecting dynamic groups and sites.

Please refrain from running any bulk scripts or making changes to dynamic groups until this is resolved.

We appreciate your patience and will provide further updates as soon as they are available.
Posted Apr 23, 2026 - 06:55 UTC
This incident affected: SafetyCulture (Web Platform).