Accounts located in the Australian and European regions may experience login issues on Android devices.
Incident Report for SafetyCulture
Resolved
This has been resolved in the newest Android app version 22.19.1.

Please update to this new version.
Posted Jun 07, 2022 - 08:25 UTC
Identified
The issue has been identified and a fix will be released soon.

As a temporary workaround, some customers have been able to resolve the issue by force closing the application and/or restarting the device.
Posted May 30, 2022 - 05:51 UTC
Investigating
We are currently investigating this issue.
Posted May 26, 2022 - 09:29 UTC
This incident affected: Sydney (AU) (iAuditor Mobile) and Dublin (EU) (iAuditor Mobile).