Training tab is not loading for some users

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 01:10 UTC

Investigating

We are aware that some users are unable to access the Training tab on the web and mobile app.
Posted Mar 04, 2026 - 20:30 UTC
This incident affected: SafetyCulture (Training).