Training tab not loading for some users

Incident Report for SafetyCulture

Resolved

This incident has now been resolved.
Posted May 26, 2025 - 06:52 UTC

Investigating

We are aware of an outage impacting our Training tab.

Our team is currently investigating.

We appreciate your patience.
Posted May 26, 2025 - 06:17 UTC
This incident affected: SafetyCulture (Training).