Unable to contact SafetyCulture Support
Incident Report for SafetyCulture
Resolved
This incident has been resolved. Customers should be able to contact our Support Teams now.

Thank you for your patience and understanding.
Posted Jul 28, 2023 - 05:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2023 - 21:08 UTC
Update
We are continuing to investigate this issue.
Posted Jul 27, 2023 - 17:50 UTC
Update
We are continuing to investigate this issue.
Posted Jul 27, 2023 - 16:52 UTC
Investigating
We are currently aware of an issue where customers are unable to contact the SafetyCulture Support team via chat, phone or email.

We are investigating this on our end. We apologize for any inconvenience caused.
Posted Jul 27, 2023 - 16:35 UTC