We are investigating problems with Federated Logout of Single Sign-On.

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Mar 16, 2023 - 03:56 UTC

Investigating

We are currently investigating this issue.
Posted Mar 15, 2023 - 08:36 UTC
This incident affected: SafetyCulture (Mobile App, Web Platform).